返回

互联网

搜索 导航

eclipse 和 android studio 编译时报 Unsupported major.minor version 52.0错解决办法

发布于: 2016-00-15   作者:Andye   来源:转载   浏览:

 version 52.0 是java8的环境。当gradle tools 升级到2.2.1时候,可能编译时候会报该错误。

很多网友说更改java version,但是很多时候无效。下面是我遇到时候的解决办法:

解决思路如下:

1.Android studio 中:

出现该问题的情况,大多数是在升级完 gradle tools 2.2.1,把android studio升级到最新2.2版本时候遇到的。

原因是,没有同步更新Android SDK Build-tools。把SDK的build-tools升级到最新就ok了。

 

2.eclipse中:

当你在android studio中升级了Android sdk,用eclipse编译时可能也会报该错误。

(虽然现在很少用eclipse,但是某些情况下还是要用的)

网友解决办法基本都是把jdk版本改成1.7,或者安装1.8然后把工程统一改成1.8版本。

 但是很有时候你希望的是基于1.7版本编译的,不希望编译的版本过高,

修复的方法很简单:

打开Android sdk manager 在 Build-tools里选择版本相对低一点的

我选择的是23.0.1

在 eclipse中android的工程进行配置一下:

在文件project.properties中添加下面一句(要是你本地已经下载好的buildtools版本):

sdk.buildtools=23.0.1

就ok了。

 

以上是最近遇到的问题,希望能够帮到各位。

 

  • 0

    开心

  • 0

    板砖

  • 0

    感动

  • 0

    有用

  • 0

    疑问

  • 0

    难过

  • 0

    无聊

  • 0

    震惊

line
IT610手机版